I checked the style guide: https://nim-lang.org/docs/nep1.html and there's no mention of this.
Should I call module procs with the module name like this?
my_utils.thisIsAProc()
Or make every proc name unique to call them like this?
thisIsAProc()
I like the first one better as it disambiguates the module name. Is there any general preference in the community?
The first one (with module name) is way better if you want people to be able to read your code. I usually do this:
from my_utils import nil
...
my_utils.thisIsAProc()
Unfortunately, templates generally assume that you have imported all symbols from their own module. (That's not a criticism. I wouldn't know a better way.) Sometimes I import entire standard modules, or I import a few operators specifically. But for my own modules, I try to avoid "*" imports (to borrow a name from Python), since readers would have no idea where to look.
I suppose if your reader has an IDE that can track down the source-code, then importing "*" and dropping the namespace is fine.